Operating-system requirements

Below you'll find applications and the operating system they require.

iOS applications

Please check all the product pages for addition requirements. Note that older versions might be listed, while they can no longer be downloaded, they might give an indication as to why you can't find an updated version on your device.

Application
7.0
8.0
9.0
10.0
retina
iPhone5
Touch Rummy HD (2.5.1)**     
Touch Rummy HD (2.4.3)**    
Touch Rummy HD (2.4)**   
Touch Rummy (2.5.1)*       
Touch Rummy (2.4.3)*      
Squeakies (1.2)*      
* Optimized for iPhone & iPod Touch
** Requires an iPad

Max OS X applications

Please check all the product pages for addition requirements.

Application
10.9
10.10
10.11
10.12
retina
64bit
Photo Desktop 2 (2.6)   
Photo Desktop 2 (2.5)     
Photo Desktop 2 (2.4.2)*    
WeatherDock (2.5.1)**   
Froq 2 (2.4.5)*      
Froq 3 (3.1)*        
Dashboard KickStart (3.3)*     
Juice (1.3)**    
DashLock (2.1)**    
* Requires an Intel processor
** Universal, runs on PowerPC & Intel